Linux FAQ

alex303

3.5" Floppy
Učlanjen(a)
19.04.2005
Poruke
1,887
Poena
63
Kada se ACPI stavi na OFF, to bukvalno gasi power management u kernelu. Zbog toga ventilatori ne ubrzavaju kada temperatura poraste. Vrati ACPI na ON, i vidi da li će se problem sa zauzećem vratiti. Ako se problem vrati, imaš neki setting u BIOS-u koji nije dobro podešen, i problem moraš da tražiš tamo.
 

Difermo

3.5" Floppy
Učlanjen(a)
13.05.2014
Poruke
1,713
Poena
48
vratio acpi=on i za divno cudo, problem se nije vratio. Hvala za resenje... Malo je hladniji, ali svakako cu morati da menjam termalnu pastu.. iako je menjana malo jace od godinu dana. Mozda nisam stavio dovoljno prosli put
 

alex303

3.5" Floppy
Učlanjen(a)
19.04.2005
Poruke
1,887
Poena
63
vratio acpi=on i za divno cudo, problem se nije vratio. Hvala za resenje... Malo je hladniji, ali svakako cu morati da menjam termalnu pastu.. iako je menjana malo jace od godinu dana. Mozda nisam stavio dovoljno prosli put

Nadam se da grešim, ali mislim da problem nije trajno rešen. Verovatno će ga neki ACPI event opet trigger-ovati. Treba mi više informacija o sistemu. Pogotovo power management sekcija u BIOS-u. I dalje mislim da je problem tamo.
 

Difermo

3.5" Floppy
Učlanjen(a)
13.05.2014
Poruke
1,713
Poena
48
Evo formatirao debian particiju i ponovo instaliram debian 10 gnome. Mozda gresim u instalaciji pa cu navesti i te korake.
Kod:
klasicno isntaliranje samo sto sam pred kraj odstiklirao print server gnome (sve sto je bilo stiklirano osim poslednje stavke system tools)

dodao contrib non-free u /etc/apt/sources.list i snimio
Kod:
apt install firmware-atheros firmware-realtek firmware-misc-nonfree

Kod:
 apt install gnome-core

Zatim u /etc/NetworkManager/NetworkManager.conf stavio managed=true
i u /etc/gdm3/daemon.conf skinuo # sa WaylandEnable=false
Posle toga ide klasicno instalacija uz sudo apt install ffmpeg mpv .....

Naravno pojavi se gnome-shell i kworker i pokusam da primenim istu tehniku. Da prvo iskljucim acpi pa da vratim na staro. I zaista nije bilo zauzeca cpu-a od strane gnome-shell i kworkera. Medjutim jedan, dva restarta i opet se vrati.. Tako da moram traziti trajno resenje jer mi gnome vise lezi. vise mi se dopada. A sa ovim kocenjem je neupotrebljiv.

Sto se tice informacija o sistemu, ne znam sta ti treba. Evo slike svih opcija u biosu (posto je stariji laptop nema ih mnogo)
1.jpg

2.jpg

3.jpg

4.jpg

5.jpg

P.S. Da napomenem da mi se ponekad desi problem da zabaguje ikonica (system tray) za network.. Stoji upitnik ili iksic iako je povezan preko lan kabla. Pre par dana kada sam prvi put stavio gnome (pre ovog instaliranja i pre kde) desilo mi se da izuzetno koci i baguje a ta "ikonica" za network treperi. Pali se i gasi sama od sebe.. PA ne znam da li problem moze biti neki drrajver za lan
 

alex303

3.5" Floppy
Učlanjen(a)
19.04.2005
Poruke
1,887
Poena
63
Čisto da napomenem. 4GB memorije je jako malo za Debian+Gnome, a mašina nema ni SSD. Tako da će rad svakako biti otežan.

Anyway, u BIOS-u stavku UEFI Boot stavi na Enabled, i odradi reinstalaciju tako što ćeš odabrati UEFI mode. Nemoj puštati da se postojeća instalacija boot-uje nakon paljenja ove stavke !! Nakon instalacije, instaliraj paket gnome-tweak-tool, i u startup-u pogasi nepotrebne stvari. Ako ne znaš šta treba, okači screenshot, pa ću ti ja reći, ili guglaj.
 

Difermo

3.5" Floppy
Učlanjen(a)
13.05.2014
Poruke
1,713
Poena
48
ODradio sve kako si rekao, i nakon instalacije stanje se pogorsalo. Sad ni acpi=off nece da ugasi gnome-shell i kworker.. Mislim ugase ali se vrati samo od sebe. Probao sam ubuntu i na njemu se desava isto. Da li bi problem nestao ako bih presao na neki drugi distro ?
 

alex303

3.5" Floppy
Učlanjen(a)
19.04.2005
Poruke
1,887
Poena
63
ODradio sve kako si rekao, i nakon instalacije stanje se pogorsalo. Sad ni acpi=off nece da ugasi gnome-shell i kworker.. Mislim ugase ali se vrati samo od sebe. Probao sam ubuntu i na njemu se desava isto. Da li bi problem nestao ako bih presao na neki drugi distro ?

Ja bi ti preporučio da batališ gnome. Probaj Manjaro XFCE.
 

Zoran021

3.5" Floppy
Učlanjen(a)
06.06.2005
Poruke
378
Poena
18
Kako da vratim rezoluciju ekrana na linuxu mint ? Imam dve u ponudi ali mi one ne odgovaraju. Uspeo sam da vratim u win10 ,ali mi je ovo ostalo,na linux mint 18.1 Cinammon .
 

Andrejee

Flash Drive
Učlanjen(a)
01.08.2019
Poruke
137
Poena
0
Pozdrav. Imao dual boot Windows 10 I Lubuntu. Obrisao Lubuntu particiju, ali zaboravio da obrisem i grub. Sada imam instaliran Windows 10 kojem ne mogu da pristupom, zbog greške grub rescue.

Butabilni Lubuntu mi ne prepoznaje, ali prepoznaje butabilni Windows 10.
Imam detaljniju poruku sa svim sto sam probao na temi Windows 10, pa ako moze neko da vidi.

Uglavnom, ovo je lose dosta, jer ne vidim izlaz. Imam Command Prompt samo kao opciju i to je to ili je l postoji nacin da se rešim grub rescue opcije sad?
Hvala.
 

Andrejee

Flash Drive
Učlanjen(a)
01.08.2019
Poruke
137
Poena
0
Hvala puno.
Sve isprobao sa tog linka,
Bootrec /fixmbr
The request could not be performed because of an I/O device error.
bootrec /fixboot
Element not found.
Bootrec /scanOS pronašao Windows instaliran.

Bcdedit /export i
The store export Command is invalid.
Bcdedit /bootdebug
The parameters are not valid.


Onda sam ispao na komande u prozoru sa tog linka i kad sam hteo da dodam u Windows u boot, opcija yes, all, ili n, prve dve probao i izašla greška:
Element not found.

Sa teme Win10 su mi preporuci li neku slatku da probam, sad cu.
Hvala još jednom, pozdrav! :)
 

Andrejee

Flash Drive
Učlanjen(a)
01.08.2019
Poruke
137
Poena
0
Rešio. Samo sam išao na diskpart, pa na list volume, select volume I shrink volume. Ostavio sam unallocated. Instalirao Win10.
Hvala.
 

domcale

3.5" Floppy
Učlanjen(a)
18.04.2009
Poruke
2,140
Poena
38
Postoji li resenje za visoku potrosnju sistemskih resursa pri pustanju video sadrzaja? Konkretno imam problem sa YT, 720p video trosi ~50% vise baterije na Linuxu u odnosu na Win pri istim uslovima (minimum brightness, isti video, nista od programa u pozadini itd). Inace je potrosnja mozda cak i manja na Linuxu, sto pracenje temperature i napona CPUa i potvrdjuje. Namestio sam HW acceleration u Brave Nightly browseru, i CPU usage je poprilicno nizi, oko 5%, ali potrosnja je i dalje tu. Igrao sam se sa powertop-om i drugim power management alatima bezuspesno. Inace sam noob za Linux, prvi put mi je daily driver duze od mesec dana :D

AMD nema linux driver za moj hardver, tako da sam na open-source amdgpu. HP laptop sa Ryzen 5 3500U, Kubuntu 20.10
 
Poslednja izmena:

domcale

3.5" Floppy
Učlanjen(a)
18.04.2009
Poruke
2,140
Poena
38
Igrao sam se i sa TLP(UI), korisna alatka. Radi power management OTB kako treba, problem je samo video decode na internetu, surf po Benchu npr. je mozda i bolji nego na Windowsu po pitanju potrosnje. Nije dealbreaker ali verujem da moze da se sredi :)
 

SuperStarr

Moderator
Super Moderator
Učlanjen(a)
25.07.2002
Poruke
8,864
Poena
83
Moram da pitam ovde jer ne nalazim zadovoljavajuči odgovor na netu.

"Pod-distro" / "sub-distro" koji sam instalirao je umro. Ostavio je dosta paketa iza sebe koji su bili na AUR repozitorijumu i sada mi YAY prijavljuje kako oni više ne postoje na AUR-u. "Missing AUR Packages:" je poruka.
Kako se radi o stvarima koje samo služe za ukras (ikone, teme, podešavanja u terminalu...) i koje nisu bitne za sistem a "prijajum" mom oku, ja bi to ostavio i ne bih brisao ali bi i da neutrališem ovu poruku koja već počinje da me živcira svaki put kada odradim sinhronizaciju sa novim paketima.

Šta i gde treba da editujem da pacman / yay počne ove pakete da ignoriše i ne proverava ima li i gde novijih verzija?

Hvala unapred!
 

alex303

3.5" Floppy
Učlanjen(a)
19.04.2005
Poruke
1,887
Poena
63
Ne razumem ovaj deo:

"Pod-distro" / "sub-distro" koji sam instalirao je umro. Ostavio je dosta paketa iza sebe koji su bili na AUR repozitorijumu i sada mi YAY prijavljuje kako oni više ne postoje na AUR-u. "Missing AUR Packages:" je poruka.

Ako sam dobro shvatio, odradi ovo:

Ako nisi čistio pacman cache sa sudo pacman -Scc, onda samo lociraj original pakete u tar.tgz formatu, i backup-uj ih u neki privremeni direktorijum.
Onda uninstaliraj sve te pakete sa sudo pacman -Rsd package name.
Obriši sve što je ostalo od tog distroa koji je puko.

Kad sve to odradiš, iz terminala idi u taj privremeni direktorijum gde si backupovao te pakete i odradi sudo pacman -U *.tar.gz

Pošto je to offline install, ni pacman ni yay neće proveravati da li postoji nova verzija niti će se buniti ako ti paketi ne postoje u AUR-u.

Kako se radi o stvarima koje samo služe za ukras (ikone, teme, podešavanja u terminalu...) i koje nisu bitne za sistem a "prijajum" mom oku, ja bi to ostavio i ne bih brisao ali bi i da neutrališem ovu poruku koja već počinje da me živcira svaki put kada odradim sinhronizaciju sa novim paketima.

Šta i gde treba da editujem da pacman / yay počne ove pakete da ignoriše i ne proverava ima li i gde novijih verzija?

Hvala unapred!

Ako nemaš original pakete u tar.tgz formatu, probaj da ih nađeš na git-u. Ako ih ima tama, onda ih samo uninstaliraj, pa ih opet instaliraj kroz git, i to je to. Ako ih ni tamo nema, onda ti ostaje samo ignore opcija kroz pacman.conf. Kontam da to već znaš kako ide i da ti je google prvo to izbacio kao rešenje.
 

SuperStarr

Moderator
Super Moderator
Učlanjen(a)
25.07.2002
Poruke
8,864
Poena
83
Ako ih ni tamo nema, onda ti ostaje samo ignore opcija kroz pacman.conf. Kontam da to već znaš kako ide i da ti je google prvo to izbacio kao rešenje.

^ Ovo je bio slučaj.
Ignorisanje kroz pacman.conf je pomoglo.
Koristan članak i video na tu temu možete pronaći na našem omiljenom Linux satju: :)
https://arcolinux.com/how-to-tell-pacman-not-to-update-a-package-like-a-kernel/
Slika u slučaju da nekome i dalje nije jasno: (edit: zanemarićete typo od 2x js60)
 

Prilozi

  • Screenshot from 2021-01-08 19-46-22.png
    Screenshot from 2021-01-08 19-46-22.png
    599 KB · Pregleda: 56
Poslednja izmena:

alex303

3.5" Floppy
Učlanjen(a)
19.04.2005
Poruke
1,887
Poena
63

ryzen

3.5" Floppy
Učlanjen(a)
19.07.2018
Poruke
909
Poena
28
Na koji nacin najbolje enkriptovati USB memoriju na Linuxu?

Procitah savete sa VeraCrypt, jel neko koristio i jel dobro resenje?
 

Space Beer

3.5" Floppy
Učlanjen(a)
09.01.2011
Poruke
4,752
Poena
63
Ako hoćeš ceo disk, onda VeraCrypt. Ako hoćeš samo neke fodlere, onda možeš i Cryptomator. Ima još gomila alata, ali ova 2 su najpopularnija. I veoma pouzdana (sigunra)
 

Space Beer

3.5" Floppy
Učlanjen(a)
09.01.2011
Poruke
4,752
Poena
63
Naravno da ne. Ni na linuxu, ni na windowsu, ni na mobilnom telefonu, IoT uređaje za kuću nemam, niti imam nameru da ih koristim ;)

cz9vaej8tqd21.jpg
 

JoRed83

Flash Drive
Učlanjen(a)
14.10.2014
Poruke
19
Poena
1
Pozdrav svima. Nadam se da nisam promašio temu, izvinjavam se ako jesam.


Ovako, na laptopu Asus X541N imam instaliran Lubuntu 20.04.2 LTS. Super mi radi sve I sada bi pored toga želeo na jednoj zasebnoj particiji da instaliram windows 7, kako bih imao dual boot. Kako bi koristio I ubuntu a I windows po potrebi.


Znam da se savetuje da se instalira prvo windows pa onda ubuntu ali ja ne mogu to da radim, jer nemam vremena. Kod mene bi bio obrnuti slučaj koji sam opisao: već imam instaliran ubuntu a pored ubuntua bi da instaliram windows 7 (ne volim 10ku).

Takođe ne želim da instaliram virtual box.


Pitanje i problem:


Već sam odredio particiju na kojoj želim da instaliram windows 7. Formatirao je ntfs.

Onda ubacio USB sa windows 7 instalacijom pripremljenom preko rufusa.

I kada u biosu izaberem da boot bude sa windows 7 usb-a, u pokušaju da pokrenem instalaciju windowsa dobijam problem opisan na slici u attachment-u.


Da li sam nešto uradio pogrešno I kako da rešim ovaj problem?


Molim za tutorial kako da instaliram windows 7 koji bi kiristio kao dual boot sa Ubuntu.

1. Već instaliran Lubuntu 20.04.2 LTS
2. Treba instalirati Windows 7 na zasebnoj particiji koji bi radio pored Ubuntu, vršen dual boot po potrebi.


Hvala unapred
 

Prilozi

  • IMG_20210427_231219.jpg
    IMG_20210427_231219.jpg
    210.4 KB · Pregleda: 19

mifune21

Flash Drive
Učlanjen(a)
09.02.2017
Poruke
172
Poena
18
Da li se nekom desavalo da update od Mozzile Firefox porusi svu istoriju i sve sacuvane pasworde, udjem sad ono prazno sve, kad se nisam slogirao, a dosta pasworda ni ne znam napamet i nekih sajtova sto sam imao u bookmarksu, znaci odlepio sam. Nestao je i ublock origin, sve sto mi je bilo podeseno
Imam onaj Intelov Clear Linux i stvarno lepo radi i do sad je bilo apdejtova ali ovo mi nikako nije jasno ????
 
Poslednja izmena:

Alukard

3.5" Floppy
Učlanjen(a)
08.09.2016
Poruke
1,689
Poena
83
Nikad u zivotu za ovih 10 godina koliko koristim linux kao glavni distro
 

mifune21

Flash Drive
Učlanjen(a)
09.02.2017
Poruke
172
Poena
18
Nikad u zivotu za ovih 10 godina koliko koristim linux kao glavni distro
Sinoc sve normalno bilo, i malo pre upalim komp i imam sta da vidim.
Ova verzija koju sam dobio je 88.0.1 a pre toga ne znam koja je bila
da li ga mogu vratiti neki backup u stanje od sinoc ? ceo sistem makar
 
Vrh Dno