»RSS Benchmark sajt

      Prikazani rezultati od 1 do 7 od ukupno 7

      Tema: Proxy polisa na Win2k8R2 domenu i problemi

      1. #1
        Member Avatar korisnika castor
        Na forumu od
        Jan 2002
        Lokacija
        Beograd
        Poruka
        1.916
      2. Moja mašina
        • MON: Dell UltraSharp U2412M
        • SND: Logitech Z-5500
        • OS: Mac OS X 10.11 El Capitan
        • LAP: Apple MBP13 E2011/Core i5@2.3/16GB/Samsung850Pro256GB+WD1TB
        • TV: Sony Bravia KDL-55W829B :D
        • Ostalo: Apple iPhone 6S 64 GB Ultra Black edition
      3. Proxy polisa na Win2k8R2 domenu i problemi

        Ola!

        Skoro smo u firmi prešli na akademsku mrežu (AMRES) i samim time dobili internet preko njih. Sve bi bilo ok da ne mora da se ide preko proxy-ja, jer tu nastaju problemi.

        Ne znam koliko ko zna oko polisa i promjena koje je MS ubacio u međuvremenu od prelaskna na IE10+, pa ću da krenem "od početka".

        LM, predstavljanjem IE10, MS je ukinuo IE Maintenance, pa je samim tim postavljanje određenih podešavanja kroz polisu u IE postalo znatno teže. Narod je počeo da se domišlja na razne načine, pa je između ostalih napisana i VB skripta koja služi samo da pogodi i isključi/uključi (zavisno od potreba, kako kome treba) podešavanje u LAN Settings za Automatically detect network settings:

        Kod:
        Option Explicit
        On Error Resume Next
        'Create a constant for the HKEY_CURRENT_USER object
        Const HKCU = &H80000001
        'Define variables
        Dim strComputer
        Dim strRegistryKey
        Dim objRegistry
        Dim strRegistryValue
        DIm binValue
        strComputer = "."
        strRegistryKey = "Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections"
        strRegistryValue = "DefaultConnectionSettings"
        'Connect to the Registry
        Set objRegistry = GetObject("winmgmts:\\" & strComputer & "\root\default:StdRegProv")
        'Retrieve the current settings. 
        objRegistry.GetBinaryValue HKCU, strRegistryKey, strRegistryValue, binValue
        'Change the 'Automatically detect settings' box to unticked
        binValue(8) = 01
        'binValue(8) = 13 - Enable this line to check the box instead of uncheck
        'Save the changes
        objRegistry.SetBinaryValue HKCU, strRegistryKey, strRegistryValue, binValue
        Da bi saobraćaj sa netom preko AMRES-a radio kako treba, potrebno je isključiti ovu opciju, za šta se koristi ova skripta, jer nijedna druga opcija u polisi ne radi. I to nije problem.

        Dalje, potrebno je upisati na odgovarajuća mjesta da se koristi proxy (Reg ključ ProxyEnable), da se definišu adrese i portovi (Reg ključ ProxyServer) i da se definišu adrese kojima se NE pristupa preko proxy-ja, a što su uglavnom lokalne adrese (Reg ključ ProxyOverride).

        Tu sad nastaje problem, jer je mixed mrežno okruženje sa Windows XP Pro SP2/3 i Windows 7/SP1.

        E, sad. Default MS podešavanje za proxy je user based, što znači da se na nivou korisnika podešava proxy i može da se, u zavisnosti od potreba, podese različiti proxy-ji za različite korisnike. Obzirom da nisam želio da se zezam dodatno i da prebacujem proxy podešavanja na nivo mašine, nastavio sam dalje da razbijam glavu.

        To razbijanje glave me dovelo dotle da sam napravio dvije login skripte - jednu sa gornjim kodom za VB i drugu sa .bat fajlom koji poziva .reg fajl i koji onda upisuje potrebne vrijednosti u gore navedene ključeve. Obzirom da podešavanje potrebnih parametara kroz polisu i kroz Control Panel --> Internet Settings, pa onda tamo upisivanje potrebnih vrijednosti - ne radi, moralo je ovako.

        To je dalje dovelo do toga da se login skripta izvrši i odradi šta treba - VBS skripta je ok, a (očigledno mi) proxy.bat fajl pravi problem. A problem je slijedeći:
        - prvo logovanje: upiše se sve što treba, internet radi,
        - drugo logovanje: podešavanja za proxy su tu, ali je upotreba proxy-ja isključena (nije čekiran kvadratić Use proxy).

        I tako stalno.

        Gledam ovo već 10 dana i kopam po internetu i ne mogu da nađem šta je problem.

        Ima li neko ideju? Ili zna kako se zove to polje, pa da proširim gornju VBS skriptu da odradi i ovo?

        Fala svima.


        Pozdrav.

        Djole
        It's the ride that matters, not the bike...

      4. #2
        Member
        Na forumu od
        Feb 2001
        Lokacija
        Beograd
        Poruka
        569
        Citat Citiram korisnika: castor Pogledaj poruku
        LM, predstavljanjem IE10, MS je ukinuo IE Maintenance, pa je samim tim postavljanje određenih podešavanja kroz polisu u IE postalo znatno teže. Narod je počeo da se domišlja na razne načine...
        misliš, ukidanjem maintenance-a postalo je lakše podesiti proxy ?

        ja ne mogu da verujem šta ti pišeš i pokušavaš da radiš kad za pravljenje proxy polise sve sa opcijom koja ti treba (a koju i mi koristimo) treba cenim oko 2 minuta.



        i još nešto, kad god pokušavaš da provališ registry setovanje za neki određeni "kvadratić" (što i ja često radim), RegShot je tvoj najbolji prijatelj.
        http://sourceforge.net/projects/regshot/
        Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1.png‎ 
Views:	101 
Size:	65,0 KB 
ID:	145966   Click image for larger version. 

Name:	2.jpg‎ 
Views:	95 
Size:	170,0 KB 
ID:	145967  
        Menjao zver : 20.07.2014. u 13:18

      5. #3
        Member Avatar korisnika Wild Boy
        Na forumu od
        Jul 2005
        Lokacija
        Novi Beograd
        Poruka
        2.701
      6. Moja mašina
        • CPU: AMD FX-8320 & CM 212 Evo Push-Pull
        • MoBo: Asus M5A99X Evo
        • RAM: 16GB Kingston DDR3
        • VGA: Sapphire 7850 2GB Dual-X
        • MON: Dell U2312HM
        • HDD: Samsung 840 120GB, Crucial MX100 256GB, WD10EZEX 1TB, Samsung HD154UI 1.5TB, ext. Verbatim 500GB
        • OPT: LG GH22N
        • Case: CM 690 II Basic, Super Flower SF-600P14XE
        • SND: Asus Xonar DG, Logitech z623
        • OS: Windows 10
        • LAP: Lenovo T470s
        • INET: DSL
        • Ostalo: G403, P10 Lite
      7. Na Computer strani polise se onemoguci promena podesavanja za proxy (konkretno admin. template inetres.admx)
        Na user strani se podesi proxy u preferences>..>ie(x).

        Ne razumem cemu tolika drama ili mozda ne razumem problem

      8. #4
        Member Avatar korisnika Kunja
        Na forumu od
        Jun 2008
        Poruka
        161
      9. Moja mašina
        • CPU: Intel e8400
        • MoBo: Dfi dk p45-T2RS
        • RAM: OCZ Reaper 2x1GB 9600+Patriot Viper 2x2GB 8500
        • VGA: Gainward 4850 GS
        • MON: Samsung 931bf
        • HDD: WD 500GB
        • OPT: DVD-RW
        • Case: Antec Sonata III
        • SND: X-230
        • INET: DSL
        • Ostalo: Logitech MX-518 , K350
      10. Pitah kolegu koji mi se pre par meseci žalio na isto i evo šta mi je napisao:

        Ovaj problem sam imao pre par meseci kod klijenta.
        Koliko se sećam fora je to što ukoliko imaš dfl i ffl na nivou 2008 R2 ili manje i IE koji je veći od verzije 9 imaš ovaj problem.
        Za IE 9 imaš patch koji rešava problem.
        Prvo smo kroz GPO spuštali podešavanja u registry i to je radilo neko vreme, nakon toga su krenuli isti simptomi kao što je navedeno.
        Na kraju smo uradili upgrade dfl i ffl na 2012 i za sada radi, ispostavilo se kao lakše nego lomljava sa skriptama

      11. #5
        Member Avatar korisnika castor
        Na forumu od
        Jan 2002
        Lokacija
        Beograd
        Poruka
        1.916
      12. Moja mašina
        • MON: Dell UltraSharp U2412M
        • SND: Logitech Z-5500
        • OS: Mac OS X 10.11 El Capitan
        • LAP: Apple MBP13 E2011/Core i5@2.3/16GB/Samsung850Pro256GB+WD1TB
        • TV: Sony Bravia KDL-55W829B :D
        • Ostalo: Apple iPhone 6S 64 GB Ultra Black edition
      13. Citat Citiram korisnika: zver Pogledaj poruku
        misliš, ukidanjem maintenance-a postalo je lakše podesiti proxy ?

        ja ne mogu da verujem šta ti pišeš i pokušavaš da radiš kad za pravljenje proxy polise sve sa opcijom koja ti treba (a koju i mi koristimo) treba cenim oko 2 minuta.
        Možda jeste postalo lakše da se podesi proxy, ali ja ranije nisam imao potrebe za time, pa ne mogu da znam ni da li je bilo lakše nekad ili sada. Takođe, i meni je trebalo 2 minute da podesim proxy u polisi da bi nakon te dve minute ustanovio da to jednostavno ne radi. Zato izmišljam toplu vodu...

        Ajde, ako te ne mrzi podijeli samnom ili sa svima nama polisu za proxy koja radi i na XP-u i na 7-ici bez problema. Hvala.


        EDIT: Koliko vidim ti si na 2012ici koja očigledno nema tih problema. Hvala za RegShot, pomaže...




        Citat Citiram korisnika: Wild Boy Pogledaj poruku
        Na Computer strani polise se onemoguci promena podesavanja za proxy (konkretno admin. template inetres.admx)
        Na user strani se podesi proxy u preferences>..>ie(x).

        Ne razumem cemu tolika drama ili mozda ne razumem problem
        Možda se ja nisam u startu dobro odrazio...

        Imam napravljenu polisu za korisnike (ugašen Computer Settings, samo User Settings je aktivan) u kome je namješteno da korisnik ne može da dođe uopšte do Internet Explorer settings. Tamo je namješteno nešto malo od stvari koje mogu da se namjeste, ali nije diran proxy niti išta od podešavanja vezano za samu konekciju.

        Onda sam napravio novu polisu koja gađa samo ta mrežna podešavanja, ali iako je isključeno Automatically detect network settings - isti checkbox je stalno bio čekiran. Onda sam našao onu VB skriptu koja je riješila taj problem, ali je ostao problem sa postavljanjem proxy-ja.

        Proxy sam podešavao preko User Configuration - Preferences - Contro Panel Settings - Internet Settings, pa onda Connections, pa LAN settings. Tako za IE 5 i 6, 7, 8. To nije radilo ni na XP-u sa IE 6 i8, ni na 7ici sa IE 9 i 10.

        Potom sa pokušao i sa direktnim upisivanjem vrijednosti u registry preko polise za tri polja koja mi trebaju (ProxyEnable, ProxyServer, ProxyOverride), pa ni to nije radilo... Onda sam našao ključeve u registry-ju i napravio .bat fajl koji poziva .reg fajl i učitava potrebne vrijednosti u registry - i to radi i na XP-u, i na 7ici. Ali ovako kako je gore opisano.





        Citat Citiram korisnika: Kunja Pogledaj poruku
        Pitah kolegu koji mi se pre par meseci žalio na isto i evo šta mi je napisao:

        Ovaj problem sam imao pre par meseci kod klijenta.
        Koliko se sećam fora je to što ukoliko imaš dfl i ffl na nivou 2008 R2 ili manje i IE koji je veći od verzije 9 imaš ovaj problem.
        Za IE 9 imaš patch koji rešava problem.
        Prvo smo kroz GPO spuštali podešavanja u registry i to je radilo neko vreme, nakon toga su krenuli isti simptomi kao što je navedeno.
        Na kraju smo uradili upgrade dfl i ffl na 2012 i za sada radi, ispostavilo se kao lakše nego lomljava sa skriptama
        Možda ispadam glup u društvu, ali šta je DFL i FFL na 2012? Da nije podizanje nivoa domena i funkcionalnosti na nivo 2012, ali na 2008 R2 serveru?

        Server je licenciran i uredno update-ovan sa svim zakrpama što MS izbacuje. Pokušao sam i sa update-om ADMX i ADML template-a na nivo Server-a 2012 (Administative Templates for Windows Server 2012 Installer - Windows8-Server2012ADMX-RTM.msi), ali nema nikakve razlike.


        Ako je rješenje problema prelazak na Server 2012, to u ovom trenutku nije opcija... *mjau**mjau**mjau*a...


        Hvala svima na pomoći i mišljenjima.

        Pozdrav.

        Djole
        Menjao castor : 21.07.2014. u 10:27
        It's the ride that matters, not the bike...

      14. #6
        Member Avatar korisnika Kunja
        Na forumu od
        Jun 2008
        Poruka
        161
      15. Moja mašina
        • CPU: Intel e8400
        • MoBo: Dfi dk p45-T2RS
        • RAM: OCZ Reaper 2x1GB 9600+Patriot Viper 2x2GB 8500
        • VGA: Gainward 4850 GS
        • MON: Samsung 931bf
        • HDD: WD 500GB
        • OPT: DVD-RW
        • Case: Antec Sonata III
        • SND: X-230
        • INET: DSL
        • Ostalo: Logitech MX-518 , K350
      16. Citat Citiram korisnika: castor Pogledaj poruku
        Možda ispadam glup u društvu, ali šta je DFL i FFL na 2012? Da nije podizanje nivoa domena i funkcionalnosti na nivo 2012, ali na 2008 R2 serveru?
        Da na to sam i mislio: DFL - Domain Functional Level i Forest Functional Level. Ukoliko su ti serveri 2008 R2 to je i najveći nivo koji možeš da postigneš za FFL i DFL.

        Ukoliko ne možeš da pređeš na Win Srv 2012 , alternativa ti je da spustiš IE na verziju 9 ili manje.

        Ako uspeš da ga nateraš da radi, javi rešenje

      17. #7
        Member Avatar korisnika castor
        Na forumu od
        Jan 2002
        Lokacija
        Beograd
        Poruka
        1.916
      18. Moja mašina
        • MON: Dell UltraSharp U2412M
        • SND: Logitech Z-5500
        • OS: Mac OS X 10.11 El Capitan
        • LAP: Apple MBP13 E2011/Core i5@2.3/16GB/Samsung850Pro256GB+WD1TB
        • TV: Sony Bravia KDL-55W829B :D
        • Ostalo: Apple iPhone 6S 64 GB Ultra Black edition
      19. Čisto da javim da je problem bio u onoj VB skripti. Kada sam je skinuo sve radi. U čemu je bio problem - ne'am pojma...
        It's the ride that matters, not the bike...

      Bookmarks

      Dozvoljeni tagovi

      • Ne možete pokrenuti nove teme
      • Ne možete odgovoriti u temi
      • Ne možete okačiti atačmente
      • Ne možete izmeniti svoje poruke
      •